Libreria MCrypt su CentOS 7 con Plesk 12

La libreria MCrypt è necessaria per alcuni CMS molto diffusi, tra i quali ad esempio Magento. Ho scritto una guida tempo fa per installare la libreria su server dotati di CentOS 6, recentemente sono passato a dei nuovi VPS dotati di Plesk e CentOS 7 e ho preferito seguire una via più facile per l’installazione di MCrypt: le nuove versioni di Plesk (dalla 12 in poi) consentono di installare più versioni di PHP, dalla versione 5.4 in poi infatti la libreria MCrypt è disponibile. Se il nostro hosting è ancora impostato su un PHP 5.2 o 5.3 è sufficiente installare le nuove versioni di PHP tramite l’apposito strumento per gli aggiornamenti che trovate in Tools and Settings:

plesk php 5.6

plesk multi php

 

dopodichè potete entrare nella sottoscrizione che necessita della libreria e cambiare facilmente la versione di PHP assegnata:

plesk mcrypt

 

plesk_centos_mcrypt

La procedura è utile anche per CMS, plugin e in generale siti che necessitano il nuovo PHP, e vi consente di non dover installare e configurare nulla via SSH. Provato su Centos 7 e Plesk 12.

Rispondi